Ansible Install Error: error: Installed distribution setuptools 0.9.8 conflicts with requirement setuptools>=11.3


I got this when trying to install Ansible from source. Needed to upgrade the setuptools in my python installation. This can be done using pip

[root@centos02 ansible]# pip install -U pip setuptools
Requirement already up-to-date: pip in /usr/lib/python2.7/site-packages
Collecting setuptools
  Downloading setuptools-34.1.1-py2.py3-none-any.whl (389kB)
    100% |████████████████████████████████| 399kB 2.7MB/s
Requirement already up-to-date: six>=1.6.0 in /usr/lib/python2.7/site-packages (from setuptools)
Collecting appdirs>=1.4.0 (from setuptools)
  Downloading appdirs-1.4.0-py2.py3-none-any.whl
Collecting packaging>=16.8 (from setuptools)
  Downloading packaging-16.8-py2.py3-none-any.whl
Collecting pyparsing (from packaging>=16.8->setuptools)
  Downloading pyparsing-2.1.10-py2.py3-none-any.whl (56kB)
    100% |████████████████████████████████| 61kB 8.2MB/s
Installing collected packages: appdirs, pyparsing, packaging, setuptools
  Found existing installation: pyparsing 1.5.6
    DEPRECATION: Uninstalling a distutils installed project (pyparsing) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project.
    Uninstalling pyparsing-1.5.6:
      Successfully uninstalled pyparsing-1.5.6
  Found existing installation: setuptools 0.9.8
    Uninstalling setuptools-0.9.8:
      Successfully uninstalled setuptools-0.9.8
Successfully installed appdirs-1.4.0 packaging-16.8 pyparsing-2.1.10 setuptools-34.1.1

Clean up the build then try again.